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    License Agreement
Your use of this software indicates your acceptance of this license 
agreement and warranty. Please carefully read these terms and con-
ditions prior to the use of this software.

Copyright
All title and copyrights in and to this software are owned by KORG 
Italy SpA (hereafter simply indicated as "Korg"). This software is pro-
tected by copyright laws and international treaty provisions.

Freeware
Although this software is free, it is not "public domain". It is a copy-
righted software program, and Korg reserves all rights. Therefore:

• This software cannot be sold, either by itself or in combination with 
any other product, without the express written permission of Korg.

• If you are a user group which is publishing a CD-ROM or floppy 
collection, you may include this software and all of its related files 
without restriction, save that the entire original package is included.

• If you are a hard disk vendor which distributes PD, shareware, and 
freeware on your disk drives, you are welcome to distribute this soft-
ware. Contact Korg for up-to date versions and information.

• Commercial publishers and distributors of CD-ROM software col-
lections, to include any and all software compilations provided as 
an adjunct to printed or online publications, may not distribute this 
software on CD- ROM without the express written permission of 
Korg.

• This software may be posted on an information service which 
charges its users for general connection time and downloading, but 
it may NOT be posted to an information service which will charge for 
the specific right to download it, without the express written permis-
sion of Korg.

• This software may be given away as a support utility for a package 
which is itself to be given away. People who need to distribute it as 
a support utility should contact Korg for up-to-date versions and in-
formation.

Please address all correspondence to: 

	 KORG Italy SpA
	 Via Cagiata, 85
	 60027 Osimo (AN) - Italy
	 www.korgpa.com

Please note that we cannot provide technical support for this soft-
ware (or any of our other freeware products).

Disclaimer of Warranty
THIS SOFTWARE AND THE ACCOMPANYING FILES ARE DISTRIBUTED 
"AS IS" AND WITHOUT WARRANTIES AS TO PERFORMANCE OR MER-
CHANTABILITY OR ANY OTHER WARRANTIES WHETHER EXPRESSED 
OR IMPLIED. NO WARRANTY OF FITNESS FOR A PARTICULAR PUR-
POSE IS OFFERED.

Distribution
This software is freeware and may be freely copied and distributed 
as long as the entire unmodified program is copied and no fee is 
charged.

Support
This software is given "as is". No support is granted by Korg.

Liability
Korg shall not be liable for errors contained in information and soft-
ware downloaded from the Korg Website, or otherwise obtained 
from the Korg Website in any manner. Korg will not in any event be 
liable for any direct, indirect, special, incidental or consequential 
damages whatsoever (including lost profits, lost data, or business 
interruption) related to any use, reproduction, modification, or dis-
tribution of the software, results, documentation or links provided 
by the Korg Website.

No Disassembly or Decryption
You may not disassemble or decompile the Software without prior 
written consent of Korg.

Transfer
Your license will automatically terminate upon any transfer of the 
Software. Upon transfer, you must deliver the Software, including 
any copies and related documentation, to the transferee. The trans-
feree must accept these License Terms as a condition to the transfer.

Termination
Korg may terminate your license upon notice for failure to comply 
with any of these License Terms. Upon termination, you must imme-
diately destroy the Software, together with all copies, adaptations 
and merged portions in any form.

Data Handling
Data may sometimes be lost due to incorrect user action. Be sure to 
backup important data. Korg will not be responsible for damages 
caused by data loss.

Disclaimer
The information contained in this manual have been carefully re-
vised and checked through. Due to our constant efforts to improve 
our products, the specifications might differ to those in the manual. 
Korg is not responsible for any eventual differences found between 
the specifications and the contents of the instruction manual &en-
dash; the specifications being subject to change without prior no-
tice.

Trademarks
Windows is a registered trademark of Microsoft Corporation. All 
other trademarks or registered trademarks are the property of their 
respective holders.
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Introduction
Thank you for using the Korg SongBook Editor for the Pa-Series 
Professional Arrangers. All models with the SongBook feature are 
supported (including Pa3X, Pa2X Pro, Pa800, Pa1X, Pa1X Pro, 
Pa1X Elite, Pa500 and Pa588).

With the SongBook Editor you can comfortably view and edit a 
Korg Pa-Series SongBook file with your PC. It allows you to:

•	 Create new Song entries.

•	 Edit most Song parameters.

•	 Rename Songs and edit parameters faster using the PC’s key-
board.

•	 Change the order of the Songs in the lists.

•	 Create and edit Custom Lists.

•	 Drag&drop entries between SongBook files.

•	 Import Standard MIDI Files and MP3 files from folders.

•	 Change Style location.

•	 Change the file path of Standard MIDI Files, MP3 files and text 
files.

All editing can be done on the files residing inside the internal 
memory of the Pa, without any need of transferring them to your 
PC. This way, you can work directly on the original data.

Installing the software

PC system requirements

You need a PC running under Microsoft® Windows® XP/Vista/7™.

Note: Windows Installer version 2.0 (or higher) is required, and can be 
freely downloaded from Microsoft’s website.

Pa3X system requirement

Pa3X with with Operating System version 1.1 or higher.

Pa2X, Pa800 system requirement

Pa2X and Pa800 updated to the latest version of the Operating Sys-
tem.

Pa1X system requirement

Pa1X, Pa1X Pro or Pa1X Elite updated to the latest version of the 
Operating System. An internal hard disk is required.

Pa500/Pa588 system requirement

Pa500/Pa588 updated to the latest version of the Operating System. 
The use of an SD card is mandatory.

Installing the software

After dowloading the installer, follow these easy steps:

1.	 Double click on the installer’s icon.

2.	 Follow the instructions appearing on the screen.

Choosing your instrument as the “target”
The first time you run the SongBook Editor, please use the Target 
parameter in the Preferences dialog box to select your instruments 
as the “target” device. This will allow the program to use the correct 
file format. You do not need to select it again later, since this setting 
will remain memorized for all following editing sessions.

Warning: Due to compatibility issues, 
�(a) if you change Target from Pa3X to any other model, all Songs cre-
ated on a Pa3X will be removed from the database.
�(b) if your target is different from Pa3X, when trying to open a Pa3X 
SongBook database, all Songs created on a Pa3X will be removed. 
�In both cases, a list of Songs to be deleted will appear, to let you con-
firm deletion.

Using removable media
During editing, you cannot see any USB memory stick connected 
to your Pa’s USB Host port. However, you can read files (like Stan-
dard MIDI Files) inside an USB memory stick connected to your 
PC USB port.

Due to their low access speed, no floppy disk or CD inserted in the 
Pa1X can be seen from the SongBook Editor.
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Workflow
Here are the general guidelines on using SongBook Editor.

Creating the Style-based SongBook entries

It is advisable to create Style-based entries on the Pa, since all actual 
values of the Style Settings will be copied in the SongBook entry. On 
the contrary, creating Style-based entries in the SongBook Editor 
would only assign default values to the entry.

1.	 On the Pa, create a new SongBook database, or edit an existing 
one.

2.	 Still on the Pa, create all Style-based SongBook entries. 

Creating the SongBook files

Prior to editing the SongBook files with the SongBook Editor, you 
must create the relevant files in the internal memory of your Pa.

Warning: Always keep a backup copy of your SongBook files!

1.	 On the Pa, save the SongBook to the internal memory, by us-
ing the relevant Media (Disk) > Save operation. A new “.SET” fold-
er will be created, containing the Book (“.SBD) and Custom List 
(“.SBL”) files.

2.	 To be safe, create a second copy with a different name, to be 
used as a backup copy.

Connecting the Pa to a PC

To make your Pa communicate with a PC running the SongBook 
Editor, you must connect your Pa to a PC. When the USB Device 
port of the Pa is connected to the USB port of a PC, the PC can see 
the internal memory of the Pa as any other storage device. You can 
directly work on the SongBook files, the Standard MIDI Files, the 
MP3 files and the TXT files contained in the Pa.

1.	 Use a standard USB cable to connect the USB Device port of 
the Pa to an USB port of the PC.

2.	 If they are still turned off, turn them on.

3.	 On the Pa, go to the Media (Disk) > USB page, and press the 
Enable button. The icon of the Pa’s internal memory should appear 
in the list of the devices connected to your PC.

Editing the SongBook files

1.	 Run the SongBook Editor software.

2.	 The first time you run the SongBook Editor, use the Target pa-
rameter in the Preferences dialog box to select your instruments as 
the “target” device. This will allow the software to use the correct file 
format. You do not need to select it again later, since this setting will 
remain memorized for all the following editing sessions.

Warning: Due to compatibility issues, 
�(a) if you change Target from Pa3X to any other model, all Songs cre-
ated on a Pa3X will be removed from the database.
�(b) if your target is different from Pa3X, when trying to open a Pa3X 
SongBook database, all Songs created on a Pa3X will be removed. 
�In both cases, a list of Songs to be deleted will appear, to let you con-
firm deletion.

3.	 From the SongBook Editor, browse the files in the internal 
memory of the Pa, and open the .SET folder containing the Song-
Book file.

4.	 Use the File > Import files… (Ctrl+I) command to add new 
Standard MIDI File- and MP3-based SongBook entries to the 
SongBook database.

5.	 Use the SongBook Editor to edit the SongBook file. You can 
create new Song entries or edit existing Song entries.

6.	 Edit the Custom Lists. You can create new Custom Lists or edit 
existing Custom Lists.

7.	 Save the edited SongBook file into the internal memory of the 
Pa (you can overwrite the existing file).

Loading the edited SongBook files

To make the edited SongBook files active, you must reload them.

●● On the Pa, use the relevant Media (Disk) > Load operation to 
load the edited “.SET” folder again. The active SongBook database 
will be updated.

Disconnecting the Pa from the PC

After editing is done, you can disconnect the Pa from the PC.

●● On the PC, click the Window’s Toolbar > Safe Hardware Re-
moval icon ( ), and select the “KORG Internal HDD USB De-
vice” option to disconnect it from the PC.
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Main screen
When you run the SongBook Editor, a window split in three panels appears in the display:

The “Book” panel. This is where the full list of 
Songs included in a “.SBD” file appears. It is 

equivalent to the “Book” page of the Pa.

The “Custom List” panel. This is where you can see all the available Custom Lists 
(“.SBL” file) associated to the selected Book (“.SBD” file). All available Custom Lists are 
included in the same file. It is equivalent to the “Custom List” pop-up menu of the Pa.
Note: To be opened, the Custom List file must reside in the same “SongBook” folder 

as the Book file.

The “Selected List” panel. This is were you can 
see the content of the selected Custom List. It is 
equivalent to the “Custom List” page of the Pa.

A standard menubar on top of the window contains the available commands. See “Menu” on page 14 for more information. For more 
information on the various parts of the main screen, see “Reference” starting from page 11.
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How to use it

Creating a new Song entry
You can create one of three types of Song entries in the Book list.

• Choose the Edit > New Song > Style (Ctrl+N) command to create 
a new Song entry based on a Style.

• Choose the Edit > New Song > MIDI (Shift+Ctrl+N) command to 
create a new Song entry based on a Standard MIDI File.

• Choose the Edit > New Song > MP3 (Alt+N) command to create 
a new Song entry based on an MP3 file. 

After having chosen one of the above, the Song dialog box will ap-
pear, to let you edit the various parameters. See “Book panel” on 
page 11 for a list of editable parameters.

When you create a new Song, you can also link the musical resource 
(Style, Standard MIDI File or MP3 file) associated to it. You can 
choose from any of the musical resources contained in your Pa’s 
internal memory.

Please keep in mind that the musical resources are not copied into 
the SongBook, but only linked to its entries. If you move the Song-
Book file to a different instrument, links can be broken, unless you 
recreate exactly the same data structure in the new instrument.

Editing a Song entry
Double-click a Song entry to open the Song dialog box and edit 
the various parameters. As an alternative, click on it with the right 
mouse button, and choose the Edit command.

If you select more than a single entry (by using Shift+Click or 
Ctrl+Click), you can click them with the right mouse button, and 
choose the Edit command to edit multiple entries at the same time.

When an entry is edited, its color changes, to help you identify the 
edited entries. After a Save or Save As operation, the color of all 
entries is reset.

Note that not all parameters can be edited. For a list of editable pa-
rameters, see “Book panel” on page 11.

Changing the view options

How to change the sorting order

Click a column’s header to select the corresponding sorting crite-
rion (by Name, Genre, Author, and so on).

Each time you choose a different sorting criterion, the previous 
criterion is considered as a “sub-criterion” for the new one. For ex-
ample, you can alphabetically order your entries by Name:

Then you change the order to Genre; inside the genre alphabetical 
ordering, entries are still alphabetically ordered by name:

How to change the ascending/descending order

Each time you click a column’s header, the ascending/descending 
order is changed.

How to resize a column

To resize a column, grab the right margin of its header, then drag it. 
To reset it to the optimum size, double-click the right margin.

How to show/hide a column

Click a column’s header with the right mouse-button. When the list 
of available options appears, check/uncheck the name of the col-
umn to be shown/hidden.

How to change the fonts and view the list in alternate colors

Choose the File > Preferences command to change the fonts and as-
sign a different background color to the various panels. You can also 
assign different background colors to the odd and even rows of the 
Book panel. (See “Preferences dialog box” on page 15.)
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Creating a new Custom List
Choose the Edit > New List (Ctrl+L) command to create a new Cus-
tom List. The new list will appear in the Custom Lists panel. Custom 
Lists are contained in an “.SBL” file saved in the same “SongBook” 
folder of the “.SBD” (Book) file.

Editing a Custom List
Click a Custom List in the Custom Lists panel to see the list’s con-
tent in the Selected List panel. You can add or delete entries, and 
change their order by dragging&dropping them, or by using the 
Move Up (Ctrl+Arrow Up) and Move Down (Ctrl+Arrow Down) 
commands.
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Frequent operations

Importing Standard MIDI Files and MP3 files
You can create new SongBook entries by importing Standard MIDI 
Files and MP3 files from folders residing in your Pa, your PC, or an 
USB memory stick connected to an USB port of your PC. You can 
import files into new or existing SongBook files.

•  Importing from the Pa is advisable, since you’ll have all the re-
ferred files already inside the instrument.

• On the Pa3X/Pa2X/Pa800: To import data from an USB memory 
stick with SongBook Editor, it must be connected to an USB port on 
your PC. When you reload the SongBook to your Pa, also move the 
stick to the USB Host port of the Pa.

Note: MP3 files are optional on the Pa800, and are only available if 
the optional EXBP-Dual MP3 board is installed. They are optional on 
the Pa1X, and are only available if the optional EXBP-MP3 board is 
installed. They are not available on the Pa500/Pa588.

Note: In case there are ID3 entries inside the imported MP3 files, these 
are converted into SongBook data (title, author…). Basic data and 
some metadata inside Standard MIDI Files are also converted into 
SongBook data (Key, Master Tranpose, Time Signature, Tempo…).

Connecting the Pa to a PC

If you want to import Standard MIDI Files and/or MP3 files from 
the Pa, connect the Pa to the PC running the SongBook Editor.

1.	 Use a standard USB cable to connect the USB Device port of 
the Pa to an USB port of the PC.

2.	 On a Pa500/Pa588, insert the SD card containing the files to be 
imported into the Pa’s dedicated slot.

3.	 If they are still turned off, turn on the Pa and the PC.

4.	 On the Pa, go to the Media (Disk) > USB page, and press the 
Enable button. The icon of the Pa’s internal memory should appear 
in the list of the devices connected to your PC.

Reading files form an removable media

If you want to import Standard MIDI Files and/or MP3 files from 
an USB memory device (for example, a memory stick) to be later 
connected to the Pa, connect the USB memory device to the USB 
port of your PC.

Importing the files

When your devices are all online, import the files.

1.	 In the SongBook Editor, choose the File > Import files (Ctrl+I) 
command. A standard file selector will appear. You can select files 
inside any of the following devices:

	 • the hard disk of your PC

	 • the internal memory of your Pa3X/Pa2X/Pa800

	 • the SD card inserted in your Pa500/Pa588

	 • the USB storage device (for example, a memory stick) con-
nected to the USB port of your PC

2.	 Select the file(s) with the “.MID”, “.KAR” and “.MP3” exten-
sions you want to import. Then click the Open command to import 
the selected Standard MIDI Files and MP3 files, and convert them 
to SongBook entries.

Loading the edited SongBook files

To make the edited SongBook files active, you must reload them.

●● On the Pa, use the relevant Media (Disk) > Load operation to 
load the edited “.SET” folder again. The active SongBook database 
will be updated.

Disconnecting the Pa from the PC

After having imported all files, you can disconnect the Pa from the 
PC.

●● On the PC, click the Window’s Toolbar > Safe Hardware Re-
moval icon ( ), and select the “KORG Internal HDD USB De-
vice” option to disconnect it from the PC.

Merging two SongBook files
You can merge entries from different SongBook files.

1.	 Run the SongBook Editor, and open the first SongBook file.

2.	 Run a second session of the SongBook Editor, and open the 
second SongBook file.

3.	 With the windows of both sessions on-screen, drag & drop en-
tries from one window to the other one. You can drag&drop Songs 
between the Book and Selected List panels. When moving a Song 
from a source Selected List to a target one, the corresponding entry 
will be automatically created at the target Book panel.

Note: When copying a Song to a different SongBook file, the Song’s 
Song Selection Number is removed.

4.	 If duplicated entries are found, you are given a choice between 
keeping the original one, overwriting it, or specifying a different 
name for the new one.

5.	 Save the modified SongBook file(s).
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Changing a Style’s position
Multiple entry editing allows for global replacement of resources. 
For example, say you moved a Style to a different location in your 
instrument; you can easily replace this Style in all entries making 
use of it. For example, if you moved the Style “Jazz Waltz” from lo-
cation <1:9> to location <10:1>, here is how to edit your SongBook 
entries to reassign the Style:

1.	 In the Book panel, click the Resource label to reorder all entries 
by Resource.

2.	 Locate and select all entries referenced to Style <1:9>, then 
right-click and choose the Edit command to open the Song dialog 
box for multiple entry editing.

3.	 In the Song dialog box, check the “bank” and “position” check-
boxes of the “Style” line, choose bank 10 and location 1, then click 
OK to close the dialog box.

4.	 Notice how all selected entries are now referenced to Style 
<10:1>.

Changing bank of Styles
Banks of Styles can be freely moved to different banks. This may be 
useful, for example, when swiching to a new instrument and having 
to reorganize the internal data structure of the User, Favorite and 
Custom Factory banks.

When Styles are moved to a different bank, links from Style-based 
SongBook entries are lost. By using the SongBook Editor, you can 
quickly and easily relink all entries to the new bank of Styles.

1.	 Load your old banks of Styles into the new User banks. Keep 
the Styles in the same location inside the new banks (for example, 
be sure the Style that was residing at location <15:3> to be loaded 
into location <20:3>, instead of, say, <20:1>).

2.	 Open the old SongBook file with SongBook Editor.

3.	 In the Book pane, click on the Resource label to group all Song-
Book entries by Style Bank number.

4.	 Select all SongBook entries linked to a particular Style Bank 
(for example, all entries linked to all Styles from <15:1> to <15:32>).

5.	 Right-click on the selected entries and choose the Edit com-
mand to open the Song dialog box for multiple entry editing.

6.	 In the Song dialog box, you can edit the “Bank” parameter, by 
checking the corresponding checkbox. Change the old number to 
the number of the bank where you loaded your Styles (for example, 
change it from 15 to 20). Confirm by clicking OK.

7.	 Notice how all selected entries are now referenced to a different 
bank of Styles (for example, from <20:1> to <20:32>).
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Changing the device and path to your Standard MIDI Files, 
MP3 files and lyrics text files
In case you move your Standard MIDI Files, MP3 files or lyrics text 
files to a different device or folder, for example from your PC’s hard 
disk to an USB memory stick, or from the root to the “Standard 
MIDI File”, “MP3” or “Lyrics” folder, it is easy to reassign them to 
the new device or folder.

When editing a single entry, you can edit both the drive unit, the file 
path and the file name. When editing multiple entries, you can only 
edit the drive unit and the file path.

1.	 Select the entry(es) to be edited, right-click it (them) and 
choose the Edit command.

2.	 When the (multiple) MIDI Song or MP3 Song open, locate the 
“Resource file” or “Text file” line (or check the “unit” and/or “path” 
checkboxes of the “Resources path” and/or “Text files path” param-
eters in case of multiple entries).

3.	 Choose (or write) the new device or path in the relevant boxes.

You can also click on the yellow folder icon ( ) to browse and 
locate the new file in the connected devices.

Storage devices, like hard disks and USB memory sticks, are repre-
sented by IDs, as in the following table:

ID Storage device

Pa3X

C2: or [label]* Internal Memroy (Hard Disk/SSD)

[label]* Storage device connected to one of the USB Host ports

Pa2X/Pa800

F2: or [label]* Internal SSD-U memory

C: or [label]* Internal Hard Disk

[label]* Storage device connected to one of the USB Host ports.

Pa1X

B: Floppy Disk

C: or [label]* Hard Disk

D: CD Drive

Pa500/Pa588

E: or [label]* SD card

* The [label] is the name assigned to the storage device.

Hint: If you keep most of your files in an USB memory stick, you can 
easily move the stick from your PC and your Pa. In this case it may be 
a good idea to choose the USB stick as the device.
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Reference

Book panel
Here you can view and edit the content of the SongBook (“.SBD” file). The Book’s content is shown in a database-like fashion, with each Song 
entry in a row, and the various parameters of the entry in adjacent columns.

The following table shows which parameters can be edited or not. 
Please see the User’s Manual for more information on their meaning.

Parameter Editable/ 
Non-editable

Sel.No. (Song Selection Number) √

Type
Resource Type 

–

Name (Song Name) √

Artist √

Genre √

Key √

Tempo –

Meter √

Master Transpose –

Synchro Start
Synchro Start button 

√

Synchro Stop
Synchro Stop button 

√

Memory
Memory button 

√

Harmony Track √

Resource
Style based entry: Style bank and number. Song based entry: 
Filepath (including name) of the associated Standard MIDI File 
or MP3 file (excluding Pa500/Pa588)

√

TXT file
Filepath (including name) of the text file associated to the 
SongBook entry 

√

SongBook files and the “.SET” folder

All SongBook files (“.SBD” and “SBL” files) must be contained in-
side the SONGBOOK folder, inside a “.SET” folder.

The Book list may be split in several files inside the SONGDB.SBD 
folder. An example of a SongBook (“.SBD”) filepath is the following:

c:\foldername.set\songbook\songdb.sbd\bank01.sbd
c:\foldername.set\songbook\songdb.sbd\bank02.sbd

...

On the contrary, there is only one file containing all the Custom 
Lists. An example of Custom List (“.SBL”) filepath is the following:

c:\foldername.set\songbook\listdb.sbl

How to open a SongBook file

Choose the File > Open command to open a “.SET” folder contain-
ing a SongBook (“.SBD”) and Custom List (“.SBL”) file. As an alter-
native, you can drag the SongBook file to the Book window, or to 
the SongBook Editor’s application icon. Also, you can double-click 
the “.SBD” file.

Note: To be opened, the Custom List file must reside in the same 
“SongBook” folder as the Book file.

Note: Dragging the SongBook file only works if the “.SBD” file is con-
tained into a correctly structured “.SET” folder.

How to choose a file format that is right to your instrument

Use the Target parameter in the Preferences dialog box to choose 
either the Pa3X, Pa2X, Pa800, Pa1X or Pa500/Pa588 as your target 
instrument. Note that Pa3X must be updated to OS version 1.1 (or 
higher) to read a SongBook Editor 1.4 file. All other Pa models must 
be updated to the latest OS version.

How to save a SongBook file

After editing, choose the File > Save or Save As... command. When 
choosing the Save... command, the files is saved at the original posi-
tion. When choosing the Save As... command, you must first create 
a “.SET” folder, then save to it. The SongBook (“.SBD”) and Custom 
List (“.SBL”) files will be saved inside.

How to exchange data between SongBook files

You can open two (or more) application sessions, open a different 
SongBook file in each of them, and exchange data between them. 
Each SongBook file will appear in a different application window. 
You can drag&drop Songs between the Book and Selected List pan-
els. When moving a Song from a source Selected List to a target one, 
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the corresponding entry will be automatically created at the target 
Book panel.

Note: When copying a Song to a different SongBook file, the Song’s 
Song Selection Number is removed.

How to import Standard MIDI Files and/or MP3 files from a 
folder

You can import all the Standard MIDI Files and MP3* files con-
tained in a folder, and automatically convert them into SongBook 
entries, by choosing the File > Import command (see Importing 
Standard MIDI Files and MP3 files). The imported entries can be 
added to an existing SongBook file, or to a new, empty SongBook 
file.

* Only on models with the MP3 player installed.

How to edit a parameter

Double-click the Song entry you want to edit to open the Song dia-
log box. As an alternative, click it with the right mouse button, and 
choose the Edit command.

Note: An entry that has been edited, but not yet saved, is shown in red. 
It returns black when you save the SongBook file.

How to edit multiple entries

Select more than a single entry, by Shift-clicking (for consecutive 
selection) or Control-clicking (for alternate selection), then click 
with the right mouse button, and choose the Edit command. Please 
be advised that some parameters cannot be modified when editing 
more than a single entry (for example, the Song name, or param-
eters pertaining to different types of entries – i.e., “mixed type”).

How to replace a resource globally

Multiple entry editing allows for global replacement of resources 
(Styles, Standard MIDI Files, MP3 files, TXT files). For more infor-
mation, see “Changing a Style’s position” on page 9, “Changing 
bank of Styles” on page 9, “Changing the device and path to 
your Standard MIDI Files, MP3 files and lyrics text files” on page 
10.

How to apply a filter to the current view

If you want to view only the Songs of a single author, or genre, or se-
lected according to other criteria, you can check the Filtered check-
box in the lower left corner of the Book panel. To define the view 
criteria press the nearby Filter... button, or choose the Edit > Filter... 
(Ctrl+F) command to open the Filter dialog box (see “Filter dialog 
box” on page 17 for details).

How to change how data are shown in the panel

See Changing the view options for information on changing the 
view options.

Custom Lists panel
Here you can view the available Custom Lists (“.SBL” files), associ-
ated to the current SongBook (“.SBD” file).

Note: To be opened, the Custom List file must 
reside in the same “SongBook” folder as the 
Book file.

How to see the content of a Custom List

Click a Custom List name to see its content 
in the Selected List panel on the right.

How to create a new Custom List

Choose the File > New List (Ctrl+L) com-
mand.

How to delete a Custom List

Select the Custom List to be deleted, then press Delete.

How to change the sorting order of the available Custom Lists

Use the Move Up (Ctrl+Arrow Up) or Move Down (Ctrl+Arrow 
Down) command to move the selected Custom List upwards or 
downwards.
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Selected List panel
Here you can view and edit the content of the Custom List (“.SBL” file) selected in the Custom List panel on the left. The Custom List’s con-
tent is shown in a database-like fashion, with each Song entry in a row, and the various parameters of the entry in adjacent columns.

How to move Song entries up/down

Simply drag&drop the entries to move them up or down the list. 
As an alternative, select the item to be moved, then choose the Edit 
> Move Up (Ctrl+Arrow Up) or Move Down (Ctrl+Arrow Down) 
command.

Other operations

See Book panel for more information on editing the Song entries.
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Menu
The menubar on top of the window is where you can access the 
available commands.

File menu

This menu contains file-related commands.

• New: Choose this command to create a new SongBook file.

• Open...: [Ctrl+O] Choose this command to open a “.SET” folder 
containing a SongBook (“.SBD”) and a Custom List (“.SBL”) file. The 
Custom List file must reside in the same directory as the SongBook 
file.

Warning: Due to compatibility issues, if your Target is different from 
Pa3X, when trying to open a Pa3X SongBook database, all Songs cre-
ated on a Pa3X will be removed. In this case, a list of Songs to be 
deleted will appear, to let you confirm deletion.

• Save: [Ctrl+S] Choose this command to save the SongBook and 
Custom Lists in edit.

Warning: If you have loaded and edited a SongBook file created on a 
Pa1X with an older OS installed (i.e., prior to version 3.01), saving 
it will make it unreadable on Pa1X exemplars running an OS older 
than version 3.01. Please update the Pa1X to the latest OS version.

Note: After a Save operation, the color of all edited entries is reset.

•  Save As...: [Ctrl+Shift+S] Choose this command to select a lo-
cation where to save the SongBook (“.SBD” file) and Custom Lists 
(“.SBL” file) being edited. When the files selector appears, create a 
new “.SET” folder, then save to it. The SongBook and Custom List 
files will be saved inside the new folder.

Note: After a Save As operation, the color of all edited entries is reset.

• Import files...: [Ctrl+I] Choose this command to import all the 
Songs contained in a folder into the current SongBook database. In 
case there are ID3 entries inside the imported MP3 files, these are 
converted into SongBook data (title, author...). Most header data  
(like Name, Key, Tempo, Time Signature/Meter and Master Trans-
pose) and some metadata are also read from Standard MIDI Files 
and converted into SongBook data.

• Export list...: [Ctrl+E] Choose this command to save the Book 
list or a Custom List as a text (“.TXT”) file. This is the same type of 
file generated by the SongBook > Page Menu > Export As Text File 
command in the Pa.

Hint: You can export a partial list by selecting some entries, using the 
Copy command, and then pasting into a text file or spreadsheet.

Hint: To print a text file, use a non-proportional font and the land-
scape page layout.

•  Preferences...: Choose this command to open the Preferences 
dialog box (see on These preferences allow you to modify the font 

and background color for each of the following parameters:), and 
set the Target instrument and the display preferences for the Song-
Book Editor.

• Quit: [Ctrl+Q] Choose this command to exit the SongBook Edi-
tor.

Edit menu

This menu contains edit commands to be applied to the selected 
item(s).

• Cut: [Ctrl+X] Choose this command to cut the selected item(s) 
and move it into the clipboard.

• Copy: [Ctrl+C] Choose this command to copy the selected item(s) 
into the clipboard. The clipboard’s content is in the “text delimited 
by tabs” format.

• Paste: [Ctrl+V] Choose this command to paste at the current po-
sition the item(s) contained in the clipboard.

• Delete: [Del] Choose this command to delete the selected item(s).

• Select All: [Ctrl+A] Choose this command to select all the entries 
in the list.

• Move Up: [Ctrl+Up] Move the selected item(s) up one position.

• Move Down: [Ctrl+Down] Move the selected item(s) down one 
position.

• New Song...: Choose this command to add a new Song to the cur-
rent list. There are three options:

	 • Style: [Ctrl+N] Song based on a Style.

	 • MIDI: [Shift+Ctrl+N] Song based on a Standard MIDI File.

	 • MP3: [Alt+N] Song based on an MP3 file. 

Note: New Songs have a default Tempo of 120 BPM. Imported entries 
get the actual Tempo of the imported Standard MIDI File.

• New List...: [Ctrl+L] Choose this command to create a new Cus-
tom List.

• Filter...: [Ctrl+F] Choose this command to open the Filter dialog 
box (see on page 22), and set a display filter. 

Help menu

This menu contains this guide and copyright information.

 



15

Preferences dialog box
This dialog box appears when you choose the File > Preferences… 
command.

Target

The first time you run the SongBook Editor, use the Target param-
eter in the Preferences dialog box to select your instruments as the 
“target” device. This will allow the software to use the correct file 
format. You do not need to select it again later, since this setting will 
remain memorized for all the following editing sessions.

Warning: Due to compatibility issues, 
�(a) if you change Target from Pa3X to any other model, all Songs cre-
ated on a Pa3X will be removed from the database.
�(b) if your target is different from Pa3X, when trying to open a Pa3X 
SongBook database, all Songs created on a Pa3X will be removed. 
�In both cases, a list of Songs to be deleted will appear, to let you con-
firm deletion.

Fonts & Colors

These preferences allow you to modify the font and background 
color for each of the following parameters:

• Odd and even lines of the Book (Book area)

• Edited lines (entries edited but not yet saved)

• Custom Lists (Custom Lists area)

• Selected List (Selected List area) 

Song dialog box
This dialog box appears when you double-click an existing Song-
Book entry, or create a new Song. Here you can edit a new or exist-
ing item.

How to enter/edit parameters

Some parameters – i.e. Song entry names – require you enter a text 
string. Note that names are case-sensitive, i.e., “Name” is not the 
same as “name”.

Other parameters allow you to choose a value from a pop-up menu.

Automatically updated pop-up menus

Each time you enter a new Song entry, all its data are added to the 
various pop-up menus, so that you can choose them when entering/
editing other entries. For example, if you enter “Rock” in the Genre 
field of a new entry, the “Rock” option will be automatically added 
to the Genre pop-up menu. Pop-up menus grow each time you en-
ter a new Song entry.

Editing multiple Song entries

When editing more than a single entry, some parameters cannot be 
edited (for example, Song names).

Editing Style based entries

With this type of entry, you can choose (respectively) the bank and 
number of the assigned Style.

(1) Parameters (2) Bank number (3) Style number  
(4) TXT file drive unit (5) TXT file path (6) Browse icon  

(7) Previous/Next buttons



16

Parameters — These are the same parameters found in the Song-
Book pages of the instrument. The Tempo value is the one saved 
into the Style Performance.

Bank number — Each bank contains a maximum of 40 Styles in 
Pa3X, 32 Styles in the other models, and 64 Styles in the EXB01 and 
EXB02 banks of Pa1X; each group of 8 Styles corresponds to one of 
the tabs shown in the Style Select window of the instrument. Here 
are the banks that can be chosen:

# Type

Pa3X

1-15 Factory

18-20 User

21-32 Favorite

Pa2X/Pa800

1-17 Factory

18-20 User

21-30 Favorite

Pa1X

1-16 Factory

17 Not used

18-20 User

21-23 Direct FD (B:\DIRECTFD.SET)

24-26 Direct HD (C:\DIRECTHD\BANK123.SET)

27-29 Direct HD (C:\DIRECTHD\BANK456.SET)

30-32 Direct HD (C:\DIRECTHD\BANK789.SET)

33 EXB01

34 EXB02

Pa500/Pa588

1-14 Factory

15-16 User

21-32 Favorite

Style number — This is the Style number inside the selected Bank. 
Please note that this number refers to a locations, not to the actual 
name of a Style; therefore, if you customized your banks, <20:1> 
might correspond to a Style named “Ballad” in a .SET, or “Jazz 
Waltz” in a different .SET.

Text drive unit and path — The text path is divided into the drive 
unit (on the left) and the actual path (on the right). This allows you 
to change the drive separately from the path, so that you can copy 
entire directories between drives, without having to re-edit long di-
rectory strings.

An example of path is the following:

c:\foldername1\foldername2\filename.txt

When editing multiple entries, you can only edit the path, but not 
the file name; this is useful if you renamed the folder, or have moved 
the text files to a different folder or directory level. Check the Text 
file path checkbox, and enter a string similar to the following one 
(without any final backslash):

c:\newfoldername1\newfoldername2

Storage devices, like hard disks and USB memory sticks, are repre-
sented by IDs, as in the following table:

ID Storage device

Pa3X

C2: or [label]* Internal Memroy (Hard Disk/SSD)

[label]* Storage device connected to one of the USB Host ports

Pa2X/Pa800

F2: or [label]* Internal SSD-U memory

C: or [label]* Internal Hard Disk

[label]* Storage device connected to one of the USB Host ports.

Pa1X

B: Floppy Disk

C: or [label]* Hard Disk

D: CD Drive

Pa500/Pa588

E: or [label]* SD card

* The [label] is the name assigned to the storage device.

Browse icon — Click this icon to open a standard file selector, and 
choose the text file.

Previous/Next buttons — Click the Previous button to edit the pre-
vious entry of the list, or the Next button to edit the next entry of 
the list, without having to close the dialog box.

OK/Cancel buttons — Click the OK button to confirm changes and 
close the dialog box, or the Cancel button to abandon the changes 
and close the dialog box.

Editing Standard MIDI File based entries

With this type of entry, you can write the full path of the Standard 
MIDI File used as the resource.

(1) Parameters (2) Standard MIDI File drive unit  
(3) Standard MIDI File path (4) TXT file drive unit (5) TXT file path  

(6) Browse icons (7) Previous/Next buttons
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Parameters — These are the same parameters found in the Song-
Book pages of the instrument. The Tempo value is only an indicator, 
and not the actual Tempo of the Song.

Standard MIDI File and text paths — The Standard MIDI File and 
text paths are divided into the drive unit (on the left) and the actual 
path (on the right). This allows you to change the drive separate-
ly from the path, so that you can copy entire directories between 
drives, without having to re-edit long directory strings.

An example of path is the following:

c:\foldername1\foldername2\filename.mid

When editing multiple entries, you can only edit the path, but 
not the file name; this is useful if you renamed the folder, or have 
moved the songs to a different folder or directory level. Check the 
Resource path checkbox, and enter a string similar to the following 
one (without any final backslash):

c:\newfoldername1\newfoldername2

Storage devices, like hard disks and USB memory sticks, are repre-
sented by IDs, as in the table seen above for the Styles.

Browse icon — Click this icon to open a standard file selector, and 
choose the Standard MIDI File or the text file.

Previous/Next buttons — Click the Previous button to edit the pre-
vious entry of the list, or the Next button to edit the next entry of 
the list, without having to close the dialog box.

OK/Cancel buttons — Click the OK button to confirm changes and 
close the dialog box, or the Cancel button to abandon the changes 
and close the dialog box.

Editing MP3 based entries

With this type of entry, you can write the full path of the MP3 file 
used as the resource (only on models with an MP3 board installed).

(1) Parameters (2) MP3 drive unit (3) MP3 file path  
(4) TXT file drive unit (5) TXT file path  

(6) Browse icons (7) Previous/Next buttons

Editing is the same seen above for Standard MIDI File based en-
tries.

Filter dialog box
This dialog box appears when you press the Filter... button in the 
lower right corner of the Book panel, or choose the Edit > Filter... 
(Ctrl+F) command. Here you can define the view filter criteria for 
the Book panel. Available filter criteria are the same as in the Pa.
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Appendix

Keyboard shortcuts
The following table shows the key combinations that can be used to 
choose menu commands.

Command Shortcut

File menu

New –

Open Ctrl+O

Save Ctrl+S

Save As... Ctrl+Shift+S

Import files... Ctrl+I

Export list... Ctrl+E

Preferences... –

Quit Ctrl+Q

Edit menu

Cut Ctrl+X

Copy Ctrl+C

Paste Ctrl+V

Delete Del

Select All Ctrl+A

Move Up Ctrl+Arrow Up

Move Down Ctrl+Arrow Down

New Song > Style Ctrl+N

New Song > MIDI Shift+Ctrl+N

New Song > MP3 Alt+N

New List... Ctrl+L

Filter... Ctrl+F

Help menu

Contents F1

About... –

Version History
Since its introduction, the SongBook Editor has been subject to im-
provements and addition of new parameters. Please find below the 
changes since version 1.0.

Version 1.4

• Now compatible with Pa3X 1.1

• Now compatible with Microsoft Windows 7™

• Added support to Unicode characters

• Changed the procedure to select the target instrument

• Bank and Location numbers can be separately entered when edit-
ing a Style-based entry

• The Key and Master Transpose values are correctly imported from 
a Standard MIDI File associated to a new SongBook entry

• Fixed a bug that caused major and minor keys to appear inverted 
in the Song dialog box

Version 1.3

• Now compatible with Pa2X and Pa500/Pa588

• Improved compatibility with Pa1X OS version 3.01 and Pa800 OS 
version 1.51

• Now compatible with Microsoft Windows Vista™

• Changed New Song-MIDI shortcut

• Fixed a bug that caused major and minor keys to appear inverted 
in the Main screen

Version 1.2

• Now compatible with Pa800 and Pa1X OS version 3.0

• Style position and Standard MIDI File/MP3/TXT file path edit-
able

• File > Import command added

• Edit > New Song menu revised

• Edited entries shown in red (or any custom color)

• Selectable file format (Pa1X or Pa800)

• Saved files are no longer compatible with Pa1X prior to OS 3.0

• New shortcuts

Version 1.1

• Now compatible with Pa1X OS version 2.5.x 

• Song Selection Number reset when copying a Song from a Song-
Book file to a different one

• Harmony Track parameter added 

• Resource parameter added
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